Can't get ORML to work

First of sorry if this is some basic problem that should be fairly trivial.
Im new to OPENRDR and Kotlin and have reached a point where google wont help me anymore.
I’ve cloned the openrndr-template and gone through the tutorials, I then wanted to test out ORML as an alternative to ML5 for better performance. But after cloning i get these error messages:

I tried moving the orml projects into the openrdnr-template and linking the gradle files, without any result. Again sorry if this is some trivial error

For me a fresh clone works just fine.

It seems like it’s looking for the local OPENRNDR 0.4 artifacts.

Right, it sounds like it’s looking for a locally built ORML instead of the available package, maybe beacuse ormlUseSnapshot is true?

If you are using the openrndr-0.4 branch of openrndr-template this is configured at openrndr-template/settings.gradle.kts at openrndr-0.4 · openrndr/openrndr-template · GitHub

You can build orml it by running ./gradlew publishToMavenLocal -Prelease.version=0.5.1-SNAPSHOT in the orml folder.

Or you could set ormlUseSnapshot to false to download the artifact.

Ps. Welcome to the forum! :slight_smile:

First of, thanks for your feedback!

I re-installed

  • openrndr 0.4
  • the openrndr template
  • orx
  • cuda
  • orml

The new installation didn’t resolve my previous error, yhat might be due to some misunderstanding on my behalf. Is it correct to clone each repository into their own folder and then link the gradle projects? I dont see how my template would gain access to the orml files otherwise.

building orml by running ./gradlew publishToMavenLocal -Prelease.version=0.5.1-SNAPSHOT
resulted in this error:

Even though im using the 0.4 branch of th openrdr-template the settings.gradle.kts does not exist. I created it manually but I didnt notice a difference.
Again sorry if these are simple errors, its my first time using git and im still unfamiliar with kotlin and its general projrct structure

Hi! Yes, each repository is supposed to be in its own folder.
I do not link the gradle projects in any way. By using publishToMavenLocal the build files are placed in a local repository which are then accessed by the other projects (if xxxxUseSnapshot is true).

If you can’t see settings.gradle.kts I suspect you are not on the right branch. You can see the file yourself at: GitHub - openrndr/openrndr-template at openrndr-0.4

If I follow these steps I can see that file:

git clone
cd openrndr-template
git fetch --all
git checkout origin/openrndr-0.4

How did you run ./gradlew publishToMavenLocal -Prelease.version=0.5.1-SNAPSHOT ? I ask because I see your error inside idea, but I normally type that in the command line. Or maybe you use a command line inside idea? I haven’t tried that.

I was using the intelliJ console which is basically powershell. I was also using IntelliJ to clone the repositories before. Im now using git to clone them and reinstalled gradle, and use the normal console to build.

after building a freshly cloned version i still cant get it to work

I ran it in the openrndr folder and also tried it in my maven repository (which i dont think is right at all).

Ive located the files in my local maven repository, as far as i understand the command

./gradlew publishToMavenLocal -Prelease.version=0.5.1-SNAPSHOT

is supposed to create a local library using them, is that correct?

thanks for your continued support!

Hi! This message looks odd:

* What went wrong:
Task '.version=0.5.1-SNAPSHOT' not found in root project 'openrndr'.

It seems to take .version=... as a task. Does the same happen if you write publishToMavenLocal first instead of last? Maybe the order matters. Find the cause in the next post.

What publishToMavenLocal should do is to write the produced libraries into


(Linux) or



Oh ignore that message. I found in Slack that someone experienced your same issue. It’s at Slack .

It seems like the issue is that the environment variable JAVA_HOME is not set.

Maybe you can do that first and try again?