Fatal error in Java Runtime Enviroment

Hello,
I am a complete newbie here.
I want to start learning kotlin and OPENRNDR but it gives me this error every time i want to build the TemplateProgram:

EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x00007ffe09ce59f0, pid=17728, tid=4688

Any help would be appreciated!

I would also appreciate if anyone could guide me on how to make the Spore OPENRNDR gif.
Spore- OPENRNDR

Hello @pakisis!

Welcome to the forum :slight_smile:

I don’t really know why that error might be happening. How did you try to run the program? By clicking the green triangle next to fun main() ? If yes, you installed IntelliJ Idea and then just cloned the openrndr-template repo?

About that gif: by looking at it I think it is

  • rendering a noise function onto a low resolution RenderTarget
  • writing text on top of it
  • downloading the pixels (using shadow)
  • sampling those pixels and using the pixel colors (maybe the brightness?) to choose a texture from a collection of textures. I see four areas, each area draws the textures with different sizes: largest ones on the top, smallest on the bottom.

Something like that? :slight_smile:

Yea, I cloned the template from the github link as said in the guide. It was built normally but when I tried to run it with the green triangle next to fun main ( ) it gave me that error every time. I thought the error was popping up because I am using Windows 11. I tried the same thing on a Windows 10 virtual machine but it gave different kind of error. So I am kind of stuck here.

Could you paste the lines that follow that error? They might reveal which JVM is being used.

Which version of Idea do you have installed?

These are the lines that follow the error in the virtual machine Windows 10:
Exception in thread “main” java.lang.IllegalStateException: primary window could not be created
at org.openrndr.internal.gl3.ApplicationGLFWGL3.createPrimaryWindow(ApplicationGLFWGL3.kt:549)
at org.openrndr.internal.gl3.ApplicationGLFWGL3.(ApplicationGLFWGL3.kt:194)
at org.openrndr.internal.gl3.ApplicationBaseGLFWGL3.build(ApplicationBaseGLFWGL3.kt:39)
at org.openrndr.ApplicationBuilderKt.application(ApplicationBuilder.kt:84)
at TemplateProgramKt.main(TemplateProgram.kt:9)
at TemplateProgramKt.main(TemplateProgram.kt)

I have the 2022.2.3 version installed on both Windows 11 and Windows 10 virtual machine.

I think that might be because it can not create an OPENGL window in the virtual machine. I would first try without a virtual machine as that adds more things that could go wrong.

How does the error look in the Windows 11 machine?

On the Windows 11 machine it gives me this every time:

 A fatal error has been detected by the Java Runtime Environment:
#
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x00007ffe09ce59f0, pid=28180, tid=6636
#
# JRE version: OpenJDK Runtime Environment Corretto-17.0.5.8.1 (17.0.5+8) (build 17.0.5+8-LTS)
# Java VM: OpenJDK 64-Bit Server VM Corretto-17.0.5.8.1 (17.0.5+8-LTS, mixed mode, sharing, tiered, compressed oops, compressed class ptrs, g1 gc, windows-amd64)
# Problematic frame:
# C  [atio6axx.dll+0x1759f0]
#
# No core dump will be written. Minidumps are not enabled by default on client versions of Windows

Does the reply here help?

Maybe upgrading or downgrading your graphics drivers helps?

Thank you, it helped me and now everything works!
It still gives me this red text though:

INFO [main] o.o.i.g.ApplicationGLFWGL3 :arrow_lower_right: 3.4.0 Win32 WGL Null EGL OSMesa VisualC DLL
INFO [main] o.o.Application :arrow_lower_right: no preload class found ‘org.openrndr.Preload’
INFO [main] o.o.i.g.ApplicationGLFWGL3 :arrow_lower_right: OpenGL vendor: ATI Technologies Inc.
INFO [main] o.o.i.g.ApplicationGLFWGL3 :arrow_lower_right: OpenGL renderer: AMD Radeon™ Graphics
INFO [main] o.o.i.g.ApplicationGLFWGL3 :arrow_lower_right: OpenGL version: 4.5.14800 Core Profile Forward-Compatible Context 22.5.1 30.0.15021.11005

Is this something that i need to be vary about?

Happy that you got it working! What was the trick?

About that red text: it’s unfortunate that it’s red, because it’s just INFO. Nothing to worry about :slight_smile:

I updated all drivers i could think of and it started working.
Thank you for your suggestion!

1 Like