Error while building

I am using the latest IntelliJ and jdk-16.0.1 but i get the following error

LF4J: Failed to load class “org.slf4j.impl.StaticLoggerBinder”.
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
Exception in thread “main” java.lang.ClassNotFoundException: org.openrndr.internal.gl3.ApplicationGLFWGL3
at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:636)
at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:182)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:519)
at org.openrndr.Application$Companion.applicationClass(Application.kt:68)
at org.openrndr.Application$Companion.run(Application.kt:43)
at org.openrndr.ApplicationKt.application(Application.kt:100)
at org.openrndr.ApplicationBuilderKt.application(ApplicationBuilder.kt:109)
at TemplateProgramKt.main(TemplateProgram.kt:12)
at TemplateProgramKt.main(TemplateProgram.kt)

Process finished with exit code 1

any ideas?
Thanks

Hi @nourako ! Welcome to the forum :slight_smile:

How does your setup look like? Did you follow OPENRNDR GUIDE or something else?

In my openrndr-template, in the project settings it says JDK 14. I’m using openrndr and orx from git because I sometimes contribute to them, but the latest available versions should also work fine.

ps. Dj Sushi wrote in the OPENRNDR Slack:

Okay, JDK 16 has some weird bugs with gradle but the newest JDK 15 works just fine :)) the app compiles nicely into an .exe binary. Thanks!

Thanks for your response. I followed Standard guide and a couple of days it was working but stopped without me changing anything :(. i also tried the JDK 14 and the same error. Should I install everything from scratch in intelliJ or something else?

Oh weird. What idea version are you on? idea has been suggesting me to update to an EAP (early adopter) version but I refused so far just in case something breaks.

You can definitely clone the template again in another folder and see if it works. I sometimes clone it again under /tmp just to test something, then delete it.

If you say “a couple of days” it should not be related to The end of jcenter and bintray

Well i just finishing rebuilding everything from scratch and it works just fine with the JDK 16 ! Maybe it was because of the end of Jcenter and bintray (which i am totally unaware of what these are i just wan to make some nice projects with OPENRNDR) . Thanks @abe !

1 Like