Gradle sync failed

Hey everyone! I wanted to try OpenRNDR and followed the instructions accordingly. However, IntelliJ didn’t get pass the first build and threw this error:

Caused by: org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed:

The full error list:

8:23 AM	Gradle sync failed: Cause: startup failed:
				General error during semantic analysis: Unsupported class file major version 60
				java.lang.IllegalArgumentException: Unsupported class file major version 60
				at groovyjarjarasm.asm.ClassReader.<init>(
				at groovyjarjarasm.asm.ClassReader.<init>(
				at groovyjarjarasm.asm.ClassReader.<init>(
				at groovyjarjarasm.asm.ClassReader.<init>(
				at org.codehaus.groovy.ast.decompiled.AsmDecompiler.parseClass(
				at org.codehaus.groovy.control.ClassNodeResolver.findDecompiled(
				at org.codehaus.groovy.control.ClassNodeResolver.tryAsLoaderClassOrScript(
				at org.codehaus.groovy.control.ClassNodeResolver.findClassNode(
				at org.codehaus.groovy.control.ClassNodeResolver.resolveName(
				at (show balloon)

Here is what I did:

  • I downloaded IntelliJ 2021.1 and installed it with the default settings.
  • I setup a new project using VCS from the openrndr template (
  • Intellij automatically begins building and indexing the project and throws this error

I’m new to IntelliJ (previously on VS) and to the JVM, so I’m not sure what Groovy has to do with Gradle.

Hi there! Welcome to the forum :slight_smile:

A pity that you had this first experience. I think IntelliJ released this new version yesterday and there may be some issues. I think Edwin is taking a look. So far he mentioned that the problem might be related to the system using JDK 16 somewhere. More news soon.

ps. not sure if it’s any use, but here one can download previous versions: Other Versions - IntelliJ IDEA

ps2. the issue seems to affect only new installs, because I’m on 2021.1 and it continues to work.

Hi @TSAO nice to see you here! As Abe said, a pity that this is your first experience :frowning: . I am quite positive the problem stems from using JDK 16. From IntelliJ one can download older JDK’s, JDK 15 should be safe. Hope you want to give this another shot :slight_smile:

How to set the JDK / SDK

Under Platform Settings → SDKs you can download them:

That makes them available for your projects.

Then you can set the right one for your current project. The Edit button takes you to the previous screen. The dropdown lets you choose your preferred SDK.

Finally, you can make sure the module is using the right one. You can choose “Project SDK” there if it’s something else. This option exists because you could have a project in which different Modules use different versions.

1 Like

Thanks so much for this detailed guide! Using JDK 14 works. Can’t wait to start exploring!